Holiday Hours

Our offices will be closed Monday December 24th and Tuesdsay December 25th in observance of the Christmas Holiday. We will reopen Wednesday December 26th @ 10am. All support requests and emails received after close of business on Friday December 21st will be responded to when we return on Wednesday the 26th in the order they were received. We apologize if this causes any inconvenience.

Help & Support

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Visual Editor not working after wordpress upgrade 3.9

Dhaval Apr 18, 2014 06:06PM EDT

I just updated my site to WordPress version 3.9 and now the Visual Editor doesn’t work. When I switch from text to visual, it looks pretty much the same and just hangs forever. Is there any thing you guys can help me with?

1 Community Answers

Best Answer
RAWfolio Support Apr 21, 2014 10:35AM EDT

Hi Dhaval,

In short, you need to update your theme to the latest version.

Why it’s happening:
The visual editor in WordPress is powered by TinyMCE, an open source WYSIWYG editor. In WordPress 3.9, TinyMCE was updated to version 4.0, which is a complete rewrite of the editor itself. Unfortunately, version 3 editor plugins, which are used to add buttons/functionality to the editor, are not compatible with version 4. Since our themes add functionality to the editor via plugins, if you have not updated your theme to the most recent version, the editor will not function, since older versions use the TinyMCE version 3 format, not version 4. All of our themes were updated prior to the 3.9 release to accommodate this change so once you update your theme to the current version, this problem will go away.


Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

F.A.Q

Got a Pre-Sales question? Take a look at our FAQ page.

support@rawfolio.com
http://assets3.desk.com/
false
rawfoliosites
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete